At least 15 good reasons to upgrade from Moodle 1.9 to Moodle 2.4 – Sponsor Presentation

Presenters:        Meredith Henson, Catalyst IT

If you are still running Moodle 1.9, this session will provide you with reasons that you should upgrade.

Thi session will focus on some of the best features of Moodle 2.0 -> Moodle 2.4 and highligh the key benefits to be gained in upgrading.

This entry was posted in Moodlemoot 2013 and tagged , . Bookmark the permalink.

One Response to At least 15 good reasons to upgrade from Moodle 1.9 to Moodle 2.4 – Sponsor Presentation

  1. Pingback: At least 15 good reasons to upgrade from Moodle 1.9 to Moodle 2.4 – Sponsor Presentation | Language Lab | Scoop.it

Leave a Reply